raksmart活动促销

分享

写回答

发帖

求助 500 错误 log已附

国外虚拟主机 国外虚拟主机 11658 人阅读 | 25 人回复

发表于 2010-12-20 22:29:43 | 显示全部楼层 |阅读模式

小弟在LP上租了一个空间,现在穿上我的asp程序后出现了500错误,错误记录如下。有没有高手提供下解决方案?

2010-12-20 13:58:16 W3SVC30559 MAIMOM 74.50.13.240 GET /Index.asp |105|80040e21|ODBC_driver_does_not_support_the_requested_properties. 80 - 210.13.99.236 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.1;+SV1;+QQDownload+663;+NetCaptor+7.5.4;+Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.1;+SV1)

回答|共 25 个

开心私塾

发表于 2010-12-21 08:24:47 | 显示全部楼层

你的这个不是错误日志吧,我记得lunarpages的windows主机plesk面板是看不到错误日志的,
你试试下面的方法看可行
首先开启父路径的支持。如果还是不行就屏蔽掉web.config文件试试。

vancal

发表于 2010-12-21 10:24:57 | 显示全部楼层

私塾先生,这个得怎么屏蔽呢?父路径已经开启了,不知道是不是因为读写权限的问题?但是单独设置hotdocs权限,没办法设置的。但是看这个记录也不像。在plesk里面有一个log选项,可以下载每天的log

开心私塾

发表于 2010-12-21 10:30:45 | 显示全部楼层

那个log日志不是错误日志,
把web.config里面的代码设置成
<configuration>
    <system.webServer>
        <httpErrors errorMode="Detailed" />
        <asp scriptErrorSentToBrowser="true"/>
    </system.webServer>
    <system.web>
        <customErrors mode="Off"/>
        <compilation debug="true"/>
    </system.web>
</configuration>
如果还是不行就有可能不支持此程序运行。

vancal

发表于 2010-12-21 20:34:26 | 显示全部楼层

私塾先生,按照你的方法还是没能解决。已经在httpdocs里面添加了这个文件,好像没有起什么作用。

[ 本帖最后由 vancal 于 2010-12-21 08:40 PM 编辑 ]

开心私塾

发表于 2010-12-22 08:24:06 | 显示全部楼层

回复 5# 的帖子

如果可以的话,可以发一些信息到我签名的邮箱里面我进去帮你设置看看。
RAKSmart

vancal

发表于 2010-12-22 21:02:15 | 显示全部楼层

私塾先生,我的相关信息发你邮箱了。烦请空了帮忙看下,谢谢!

开心私塾

发表于 2010-12-23 08:11:37 | 显示全部楼层

回复 7# 的帖子

恩,好的,

vancal

发表于 2010-12-24 16:04:51 | 显示全部楼层

非常感谢私塾先生的热心帮助,一直在帮忙调试

vancal

发表于 2010-12-24 16:51:30 | 显示全部楼层

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x2d3c Thread 0x4014 DBC 0x1911024 Jet'.

/conn.asp, line 4

详细出错信息。
您需要登录后才可以回帖 登录 | 注册

本版积分规则