raksmart活动促销

分享

写回答

发帖

[经验] 菜鸟求救:IP1800,PV12600 服务暂时不可用

HostMonster HostMonster 4882 人阅读 | 9 人回复

发表于 2012-8-3 23:08:08 | 显示全部楼层 |阅读模式

各位大侠,小弟新手,请问现在网站IP1800,PV12600该使用什么样的套餐才能解决网站服务不可用的问题?
在网上找了一些帖子学习,说增加服务器内存可以解决,请问如何添加内存,是否需要更改套餐?

CPU差不多每小时节流3567.093 seconds ,网站文件6W多个

错误提示:
Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 503 Service Temporarily Unavailable error was encountered while trying to use an ErrorDocument to handle the request.

Error logs:
[Fri Aug 03 09:06:03 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Fri Aug 03 09:06:03 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Fri Aug 03 09:06:03 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
.....

回答|共 9 个

20111208sbd

发表于 2012-8-4 09:01:18 | 显示全部楼层

应该是服务器的问题吧,联系下主机商问问
回复 支持 反对

使用道具 举报

xiaosen1860

发表于 2012-8-6 10:16:44 | 显示全部楼层

谢谢解答
回复 支持 反对

使用道具 举报

kyxt

发表于 2012-8-6 17:24:56 | 显示全部楼层

流量不大,你用的是虚拟主机吧,虚拟主机得联系主机商,看看是什么问题,加内存是对服务器而言的
回复 支持 反对

使用道具 举报

xiaosen1860

发表于 2012-8-9 15:07:09 | 显示全部楼层

谢谢回复,问了服务器供应商,得到的回复是他们的服务器运转正常,汗,说我的网站问题。
依然出现这个提示:
Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 503 Service Temporarily Unavailable error was encountered while trying to use an ErrorDocument to handle the request.
回复 支持 反对

使用道具 举报

20111208sbd

发表于 2012-8-9 15:38:28 | 显示全部楼层

xiaosen1860 发表于 2012-8-9 03:07 PM
谢谢回复,问了服务器供应商,得到的回复是他们的服务器运转正常,汗,说我的网站问题。
依然出现这个提示 ...

他们没有说是什么原因吗?错误日志上说不支持NoCase,是不是你做了什么操作后出现的
回复 支持 反对

使用道具 举报

xiaosen1860

发表于 2012-8-9 18:46:15 | 显示全部楼层

20111208sbd 发表于 2012-8-9 03:38 PM
他们没有说是什么原因吗?错误日志上说不支持NoCase,是不是你做了什么操作后出现的 ...

好像没有,呵呵,都是间断性的,晚上的时候基本开不了网站,蜘蛛爬的比较多,麻烦大哥看看,这个是今天的日志:

[Thu Aug 09 04:42:05 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:05 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:05 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:05 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:05 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:05 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:07 2012] [error] [client 199.21.99.75] File does not exist: /usr/local/apache/htdocs/robots.txt
Use of uninitialized value $1 in concatenation (.) or string at /usr/local/cpanel/cgi-sys/fourohfour.cgi line 31.
[Thu Aug 09 04:42:10 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:11 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:12 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] *
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] About to connect() to 184.106.230.54 port 80 (#0)
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] *
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244]   Trying 184.106.230.54...
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] * connected
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] * Connected to 184.106.230.54 (184.106.230.54) port 80 (#0)
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] > POST /geolocation/getInformation.php HTTP/1.1\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] Host: 184.106.230.54\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] Accept: */*\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] Referer: http://betterbizlist.com/listing/results.php\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] Content-Length: 64\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] Content-Type: application/x-www-form-urlencoded\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] \r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] * upload completely sent off: 64 out of 64 bytes
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] < HTTP/1.1 200 OK\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] < Date: Thu, 09 Aug 2012 10:43:35 GMT\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] < Server: Apache/2.2.22 (EL)\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] < X-Powered-By: PHP/5.2.17\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] < Content-Length: 144\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] < Connection: close\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] < Content-Type: text/html; charset=UTF-8\r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] < \r
[Thu Aug 09 04:42:14 2012] [error] [client 66.249.67.244] * Closing connection #0
[Thu Aug 09 04:42:14 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:16 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:16 2012] [error] [client 66.249.67.121] Premature end of script headers: group.php
[Thu Aug 09 04:42:21 2012] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] *
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] About to connect() to 184.106.230.54 port 80 (#0)
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] *
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100]   Trying 184.106.230.54...
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] * connected
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] * Connected to 184.106.230.54 (184.106.230.54) port 80 (#0)
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] > POST /geolocation/getInformation.php HTTP/1.1\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] Host: 184.106.230.54\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] Accept: */*\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] Referer: http://betterbizlist.com/listing/results.php\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] Content-Length: 64\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] Content-Type: application/x-www-form-urlencoded\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] \r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] * upload completely sent off: 64 out of 64 bytes
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] < HTTP/1.1 200 OK\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] < Date: Thu, 09 Aug 2012 10:43:45 GMT\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] < Server: Apache/2.2.22 (EL)\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] < X-Powered-By: PHP/5.2.17\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] < Content-Length: 144\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] < Connection: close\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] < Content-Type: text/html; charset=UTF-8\r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] < \r
[Thu Aug 09 04:42:23 2012] [error] [client 207.46.13.100] * Closing connection #0

回复 支持 反对

使用道具 举报

20111208sbd

发表于 2012-8-10 09:22:13 | 显示全部楼层

你是说间歇性的,那可能是由于这些蜘蛛过度爬行你的网站导致的,从你的日志上看,每次蜘蛛爬过后就会出现nocase报错。
回复 支持 反对

使用道具 举报

xiaosen1860

发表于 2012-8-11 11:02:51 | 显示全部楼层

谢谢回复,修改了robots,解决问题{:soso_e121:}
回复 支持 反对

使用道具 举报

20111208sbd

发表于 2012-8-11 11:06:27 | 显示全部楼层

恩,可以在robots里面添加代码禁止一些蜘蛛爬行
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

HostMonster讨论

HostMonster
优惠码:优惠链接
介绍:HostMonster美国主机商成立于1996年,总部位于犹他州普罗沃,提供主机托管服务,在业内有比较有实力,而且口碑也不错。HostMonster美国主机性价比较高,而且基本不会额外收取费用,其无限型方案支持无限磁盘空间,无限带宽和电子邮件帐户,提供免费域名1个。
查看更多

xiaosen1860

发表主题